1с схема компоновки данных программно отбор

v8: Как установить программно отбор СКД?

IKSparrow 25.10.2012 13:44
Прочитано: 45275
Код следующий:

Мой отбор ни фига не учитывается. Что не так делаю?

Yandex
Возможно, вас также заинтересует
Mokey 25.10.2012 13:58
Ответ № 1
ВидОбъекта.ПравоеЗначение = «Справочник.ИсторияПользователей»;
вот это вот что такое? тут должно быть значение вида объекта, т.е. ссылка на элемент справочника.
IKSparrow 25.10.2012 14:01
Ответ № 2
(1) Нееет, там тип строка. Т.ё. не сам элемент какого-то справочника, а наименование справочника. Вернее наименование его типа, как оно записано в определённом регистре.
Gnost 25.10.2012 16:00
Ответ № 3
Пользователь @Monkey правильно вам говорит

ЭлементОтбораКомпоновкиДанных.ПравоеЗначение (DataCompositionFilterItem.RightValue)
ЭлементОтбораКомпоновкиДанных (DataCompositionFilterItem)
ПравоеЗначение (RightValue)
Использование:

Содержит правое значение элемента отбора.

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:

Тип правого значения может быть полем, остальные варианты зависят от левого значения. Это может быть его тип левого значения, либо, если слева выбрано поле, может использоваться тип поля.

Источник

Программная установка параметров и отборов СКД

Иногда возникает необходимость устанавливать отборы и параметры СКД программно. При открытии формы, например, или при формировании отчета на сервере для дальнейшей его отправки на почту.

И если с параметрами все предельно просто — информации в сети полно, то вот отборы у меня отняли много времени. В этой статье я приведу код, с помощью которого можно устанавливать отборы и параметры СКД программно.

Как я уже говорил — с параметрами все просто. У этих элементов есть метод «Найти» и поэтому функция выглядит так:

Вызов процедуры при открытии формы принимает следующий вид:

С отборами сложнее по 2 причинам:

  1. У отборов нет метода «Найти» и приходится делать перебором
  2. Отборы не являются предустановленными настройками компоновщика и поэтому их нужно будет добавлять, в случае отсутствия

Но код не намного сложнее, когда уже знаешь что писать:

Ну и вызов этой процедуры:

По большей части статью писал для себя, потому что возникла необходимость программной установки отбора в отчете СКД и я уверен, что я уже делал это несколько раз. Но информацию в интернете найти не смог. Возможно плохо искал. Теперь же мне не придется искать долго.

В любом случае — буду рад, если это еще кому-то пригодится.

4 комментария

КомпоновщикНастроек есть в отчетах. А я эту функцию вызываю из справочников, документов и при программном формировании скд.

Добрый день, прошу помощи. При выводе результатов отчета в СКД, после создания макета заголовка, в печатной форме заголовок выводится после результатов отбора и введенных параметров. А нужно чтобы выводилось над ними. Подскажите где в скд находятся настройки вывода последовательности указанных данных?

Спасибо! Очень полезно, кусочек кода по установке отборов и мне пригодился.

Добрый день!
Пытаюсь открыть форму отчёта, сделанного на СКД, из формы другого документа. Не удаётся добиться формирования отчёта с передаваемыми параметрами. В форме документа:
ПараметрыДляОтчета = Новый Структура;
ПараметрыДляОтчета.Вставить(«ДатаДокумента», Объект.Дата);
ОткрытьФорму(«Отчет.ОтчетПоРегиструОстатковТоваров.Форма»,ПараметрыДляОтчета);
В форму отчёта эти параметры передаются.
СКД устанавливает свой параметр Период. Устанавливаю его, а также параметр ДатаДокумента,
который подразумевается использовать в запросе отчёта в процедуре ПриСозданииНаСервере():
Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
ПараметрДанныхПериод = Настройки.ПараметрыДанных.Элементы[0];
ПараметрДанныхПериод.Значение = Параметры.ДатаДокумента;
ПараметрДанныхПериод.Использование = Истина;
ПараметрДанныхДатаДокумента = Настройки.ПараметрыДанных.Элементы[1];
ПараметрДанныхДатаДокумента.Значение = Параметры.ДатаДокумента;
ПараметрДанныхДатаДокумента.Использование = Истина;
Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
Проверяю в процедуре ПередЗагрузкойВариантаНаСервере():
Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти(«ДатаДокумента»);
Параметр с нужным значением в настройках имеется. Аналогично для параметра Период.
В процедуре ПриОбновленииСоставаПользовательскихНастроекНаСервере()
значения параметров уже другие. И результат отчёта, соответственно, другой.
С чего бы и как бороться с таким явлением?
В какой момент компоновщик выполняет отчёт при открытии формы?

Источник

СКД. Работа с программным отбором, группировкой, набором данных, пользовательскими полями.

// Процедура устанавливает значения параметров в запросе.
// Имя — Имя параметра
// Значение — Значение для отбора
Процедура УстановитьПараметрКомпоновки ( Имя , Значение )
КомпоновкаДанныхПараметр =
КомпоновщикНастроек . Настройки . ПараметрыДанных . Элементы . Найти ( Имя );
Если НЕ( КомпоновкаДанныхПараметр = Неопределено) Тогда
КомпоновкаДанныхПараметр.Значение = Значение ;
КомпоновкаДанныхПараметр.Использование = Истина ;
Иначе Сообщить( «Параметр » + Имя + » не найден » );
КонецЕсли;
КонецПроцедуры

// Процедура устанавливает отбор по полям запроса.
// Имя — Имя поля
// Значение — Значение для отбора
// ВидСравнения — ВидСравненияКомпоновкиДанных
Процедура УстановтьОтборПоПолюКомпоновки ( Имя , Значение , ВидСравнения )
Для Каждого ЭлементОтбора Из КомпоновщикНастроек . Настройки . Отбор . Элементы Цикл
Если ЭлементОтбора . ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( Имя ) И ЭлементОтбора . ВидСравнения = ВидСравнения Тогда
КомпоновщикНастроек . Настройки . Отбор . Элементы . Удалить ( ЭлементОтбора );
КонецЕсли;
КонецЦикла;
ЭлементОтбора = КомпоновщикНастроек.Настройки . Отбор . Элементы . Добавить ( Тип ( «ЭлементОтбораКомпоновкиДанных» ));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( Имя );
ЭлементОтбора.ВидСравнения = ВидСравнения;
ЭлементОтбора.ПравоеЗначение = Значение ;
ЭлементОтбора.Использование = Истина ;
КонецПроцедуры

ниже приведенный материал взят отсюда //infostart.ru/public/19793/

// Процедура добавляет или удаляет набор данных из схемы компоновки данных
//
// Схема — СхемаКомпоновкиДанных, схема, в которой нужно добавить(удалить) набор данных
// СхемаИсточник — СхемаКомпоновкиДанных, схема из которой копируется набор данных
// ИмяНабора — Строка
// Добавить — Булево
// НаборДанныхРодитель — НаборДанныхОбъединениеСхемыКомпоновкиДанных
Процедура ДобавитьУдалитьНаборДанных ( Схема , СхемаИсточник , ИмяНабора , Добавить , НаборДанныхРодитель )
НаборДанных = НайтиНаборДанных ( Схема . НаборыДанных , ИмяНабора );
Если Добавить Тогда
Если НаборДанных = Неопределено Тогда
НаборДанныхИсточник = НайтиНаборДанных ( СхемаИсточник . НаборыДанных , ИмяНабора );
НаборДанных = НаборДанныхРодитель . Элементы . Добавить ( Тип ( «НаборДанныхЗапросСхемыКомпоновкиДанных» ));
НаборДанных . Имя = НаборДанныхИсточник.Имя ;
НаборДанных . ИсточникДанных = НаборДанныхИсточник . ИсточникДанных ;
НаборДанных . Запрос = НаборДанныхИсточник . Запрос ;
КонецЕсли;
Иначе
Если НаборДанных <> Неопределено Тогда
НаборДанныхРодитель . Элементы . Удалить ( НаборДанных );
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Функция НайтиНаборДанных ( НаборыДанных , Имя )
Если НаборыДанных = Неопределено Тогда
Возврат Неопределено ;
КонецЕсли;

Для каждого НаборДанных Из НаборыДанных Цикл
Если НаборДанных . Имя = Имя Тогда
Возврат НаборДанных ;
КонецЕсли;

Если ТипЗнч ( НаборДанных) = Тип ( «НаборДанныхОбъединениеСхемыКомпоновкиДанных» ) Тогда
Результат = НайтиНаборДанных ( НаборДанных . Элементы , Имя );
Если Результат <> Неопределено Тогда
Возврат Результат ;
КонецЕсли;
КонецЕсли;
КонецЦикла;
В озврат Неопределено;
КонецФункции

// Функция находит группировку в компоновке
// Структура — КомпоновщикНастроек.Настройки.Структура
// Имя — Имя поля в группировке
// Возвращаемое значение: ПолеКомпоновкиДанных
Функция НайтиГруппировку ( Структура , Имя , ВидГруппировки = «Поле» )
Для Каждого Элемент Из Структура Цикл
Если ТипЗнч ( Элемент ) = Тип ( «ТаблицаКомпоновкиДанных» ) Тогда
Результат = НайтиГруппировку ( Элемент . Строки , Имя );
Если Результат <> Неопределено Тогда
Возврат Результат ;
КонецЕсли;

Результат = НайтиГруппировку ( Элемент . Колонки , Имя );
Если Результат <> Неопределено Тогда
Возврат Результат;
КонецЕсли;
ИначеЕсли ТипЗнч ( Элемент ) = Тип ( «ГруппировкаТаблицыКомпоновкиДанных» ) Тогда
Для Каждого Поле Из Элемент.ПоляГруппировки.Элементы Цикл
Если Поле.Поле = Новый ПолеКомпоновкиДанных ( Имя ) Тогда
Если ВидГруппировки = «Поле» Тогда
Результат = Поле ;
Иначе
Результат = Элемент ;
КонецЕсли;
Возврат Результат ;
КонецЕсли;
КонецЦикла;
Результат = НайтиГруппировку ( Элемент . Структура , Имя );
КонецЕсли;
КонецЦикла;

Возврат Результат ;
КонецФункции

// Процедура добавляет в каждую группировку отчета отбор по непустому значению
// Структура — КомпоновщикНастроек.Настройки.Структура
// ДоступныеПоляГруппировок — КомпоновщикНастроек.ДоступныеПоляГруппировок
Процедура ОтборПоНепустым ( Структура )
Для Каждого Элемент Из Структура Цикл
Если ТипЗнч ( Элемент ) = Тип ( «ТаблицаКомпоновкиДанных» ) Тогда
ОтборПоНепустым ( Элемент.Строки );
ОтборПоНепустым ( Элемент.Колонки );
ИначеЕсли ТипЗнч ( Элемент ) = Тип ( «ГруппировкаТаблицыКомпоновкиДанных» ) Тогда
Для Каждого Поле Из Элемент . ПоляГруппировки . Элементы Цикл
ЭлементОтбора = Неопределено;
Для Каждого ЭлементОтбора1 Из Элемент . Отбор.Элементы Цикл
Если ЭлементОтбора1 . Представление = «Отбор по непустому» Тогда
ЭлементОтбора = ЭлементОтбора1 ;
КонецЕсли;
КонецЦикла;

Если ЭлементОтбора = Неопределено Тогда
ЭлементОтбора = Элемент . Отбор . Элементы . Добавить ( Тип ( «ЭлементОтбораКомпоновкиДанных» ));
ЭлементОтбора . Представление = «Отбор по непустому» ;
КонецЕсли;
ЭлементОтбора . ЛевоеЗначение = Поле . Поле ;
ЭлементОтбора . ВидСравнения = ВидСравненияКомпоновкиДанных . Заполнено ;
ЭлементОтбора.Использование = Истина;
Параметр = Элемент . ПараметрыВывода . НайтиЗначениеПараметра( Новый ПараметрКомпоновкиДанных ( «FilterOutput» ));
Параметр . Использование = Истина;
Параметр . Значение = ТипВыводаТекстаКомпоновкиДанных . НеВыводить ;
КонецЦикла;
ОтборПоНепустым ( Элемент . Структура );
КонецЕсли;
КонецЦикла;
КонецПроцедуры

// Процедура добавляет значения интервалов в пользовательское поле
// ПолеИнтервалы — ПользовательскоеПолеВыборКомпоновкиДанных
// Интервал — Строка содержащия границы интервалов: 30,60,90
Процедура УстановитьПользовательскоеПолеИнтервал ( ПолеИнтервалы , Интервал )
Если ПустаяСтрока ( Интервал ) Тогда
Возврат;
КонецЕсли;

Стр = Интервал ;
Стр = СтрЗаменить ( Стр , «,» , Символы . ПС );
ПредИнтервал = «0» ;

Для Счетчик = 1 По СтрЧислоСтрок ( Стр ) Цикл
ТекИнтервал = СокрЛП ( СтрПолучитьСтроку ( Стр , Счетчик ));
Вариант = ПолеИнтервалы . Варианты . Элементы . Добавить ();
Вариант . Использование = Истина;
Если Счетчик = 1 Тогда
Вариант . Значение = «До » + ТекИнтервал ;
Вариант . Представление = «До » + ТекИнтервал ;
Иначе
Вариант . Значение = «От » + ПредИнтервал + » до » + ТекИнтервал ;
Вариант . Представление = «От » + ПредИнтервал + » до » + ТекИнтервал ;
КонецЕсли;

Группа = Вариант . Отбор . Элементы . Добавить ( Тип ( «ГруппаЭлементовОтбораКомпоновкиДанных» ));
Группа.Использование = Истина;
Группа.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных . ГруппаИ ;

Если Счетчик > 1 Тогда
ЭлементОтбора = Группа . Элементы . Добавить ( Тип ( «ЭлементОтбораКомпоновкиДанных» ));
ЭлементОтбора . Использование = Истина;
ЭлементОтбора . ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( «ДнейПросрочки» );
ЭлементОтбора . ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно ;
ЭлементОтбора . ПравоеЗначение = Число ( ПредИнтервал );
КонецЕсли;

ЭлементОтбора = Группа . Элементы . Добавить ( Тип ( «ЭлементОтбораКомпоновкиДанных» ));
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( «ДнейПросрочки» );
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных . Меньше ;
ЭлементОтбора.ПравоеЗначение = Число ( ТекИнтервал );
ПредИнтервал = ТекИнтервал ;

Вариант = ПолеИнтервалы . Варианты.Элементы . Добавить ();
Вариант . Значение = «Более » + ПредИнтервал ;
Вариант . Представление = «Более » + ПредИнтервал ;

Группа = Вариант . Отбор . Элементы . Добавить ( Тип ( «ГруппаЭлементовОтбораКомпоновкиДанных» ));
Группа . ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных . ГруппаИ ;

ЭлементОтбора = Группа . Элементы . Добавить ( Тип ( «ЭлементОтбораКомпоновкиДанных» ));
ЭлементОтбора . ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( «ДнейПросрочки» );
ЭлементОтбора . ВидСравнения = ВидСравненияКомпоновкиДанных . БольшеИлиРавно ;
ЭлементОтбора . ПравоеЗначение = Число ( ПредИнтервал );
КонецПроцедуры

Источник

Оцените статью
REMNABOR
Adblock
detector